让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表查看熊茂祥的文章

ROS云管理项目(仅供内部使用)

由于大量的ROS需要日常维护,批量管理尤为重要。而脚本又是常用ROS管理途径之一,所以批量下发脚本是云管理的核心功能。

对加入云管理的节点支持主动推送脚本和被动推送脚本。(双通道确保灵活性和灾备。)

主动云管理以实现以下功能:(用于紧急更新,无次数限制。)
1.可针对单个或多个节点推送单个或多个脚本,并返回每个节点的推送结果,然后记录到历史操作日志。
2.可记录下每个节点的名称,硬件编码,ROS系统版本,ROS硬件型号,推送接口。
3.可按节点分组,对分组执行特定脚本。
4.可对节点配置状态检测,检测节点的硬件锁,喵口令,拨号宽带是否正常。
5.可在线编辑保存脚本模板,需要调用时选择即可。
6.可对脚本进行权限分级,防止未经授权的用户越级调用脚本。(风险控制)
7.可对节点权限分级,防止未经授权的用户越级对其他节点执行脚本。(风险控制)
8.云管理与ROS对接为IP名单和SSL证书双重鉴权。(安全永远是最高保障级别)
9.云管理登录需验证用户密码及(邮箱校验码或短信校验码)。(安全永远是最高保障级别)

被动云管理以实现以下功能:(用于日常更新,每天一次。)
1.对节点分组,不同组拿到不同的执行脚本。
2.记录每个节点每次来拿脚本的时间。
3.云管理与ROS对接为SSL证书前置鉴权,序列号和密匙2次鉴权。(安全永远是最高保障级别)

以上代码均为原创,不调用任何第三方模块,并且提交参数全部正则式白名单字符过滤。
PS:被运维耽误的开发

» 阅读全文

Tags: ros, mikrotik, 云管理, cloud, 维护

[置顶] 云交换产品简介


特点介绍:
1.可自助注册,自助修改VRF标识进行组网。方便用户及时调整业务及创建业务。(同VRF标识可互相通信,不同VRF标识则互相隔离。)
2.具备邮件通知,可在业务点状态出现变化时通知对应负责人。
3.云交换服务器使用BGP多线服务器接入,完美解决多业务点不同运营商的问题。
4.云交换服务器跨国使用双程CN2互连,对跨国链路进行优化。可有效降低丢包率,提高稳定性。
5.云交换服务器之间互连高可用方案,当云服务器默认交互链路中断后会自动绕路互连。(尽量减少故障带来的网络中断,大幅增加网络可靠性。)
6.即使各业务点没有公网IP,不同运营商,也可以完美解决内网互通问题。
7.多业务点互通并不经过NAT转换,所有业务点均可以看到真实的源IP,确保业务点服务端可以正常按IP做ACL策略及日志审计。
8.服务资费价格平易近人,硬件产品价格也更是极具竞争力。
9.可接受定制化需求。(比如基于2层互通的云交换)

针对场景:
1.公司有多个业务节点,分布在全国各地,各地业务点均需要使用内部OA,ERP系统。
2.收银软件行业,需要加密通信和高可用内部互通网络。
3.外资企业有和境外业务点内网互通数据的需求。
可定制化:更高的多链路备份,及更优的网络线路或入口点。更多的云交换细节功能需求。

» 阅读全文

Tags: ros, 穿透, 内网, 管理, 云交换

2018.1.13成都MUM(已更新视频)



本人MikroTik见面会演讲内容《云穿透接口》:点击下载

» 阅读全文

Tags: mikrotik, mum, 成都, 见面会, 云穿透

CTS穿透自动协议切换脚本(已添加脚本)

近期由于CTS2,CTS5(青岛服)PPTP协议出现异常,本站非常重视该问题,并且希望今后能避免这种问题出现。为此编写了自动切换协议脚本。用户只需修改脚本里对应的几个参数,然后定时执行,即可在侦测到问题时自动更换连接穿透服务器的协议。建议用户将该脚本加入到定时运行,若之前已存在CTS的连接,则会自动更名。建议5-10分钟循环执行一次。(取消了切换到PPTP)

» 阅读全文

Tags: ros, cts, vpn, 穿透, 切换

云交换公测使用简介

内测服务器IP为cts7.cat-home.org,有自助页面,和穿透自助差不多。
在自助页面添加VRF标识后,使用以下脚本来对接到服务器。终端路由只会接收到同VRF标识的其他终端路由表推送。
所以如果想多个节点的内网互通首先需要让多个账号的VRF标识一致才行,修改或添加VRF标识需要在WEB自助里断开下客户端,重连后生效。当在2边ROS的ip route里看到对端的网段为ADO状态即为成功对接。

###定义OSPF的ID###(随便填,但是尽量随机写一个)
:global ospfid "2.2.2.2"
###定义对端内网段###
:global dstnet "192.168.88.0/24"
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=$ospfid
/routing ospf network add area=backbone network=172.32.56.1/32
/ip route rule add dst-address=172.32.56.0/24 table=main
###以下规则要移到顶端###
/ip firewall nat add action=accept chain=srcnat comment="CSW" dst-address=$dstnet

建议在防火墙和标记中对目标地址为对端内网段的范围进行action=accept
不明白的地方可以+Q群71773725问

示意图:

» 阅读全文

Tags: 云交换, ros, 加速, 互通, 局域网

Records:10612345678910»