让网维变得简单,快速,准确。拒绝浪费时间,解放出更多的时间陪陪家人。 注册 | 登陆
浏览模式: 标准 | 列表全部文章

温度电压异常报警

ROS脚本代码
  1. #定义温度报警阀值比如30度  
  2. :local tempbeep 30  
  3. #定义电压报警阀值比如23.2V  
  4. :local volbeep 232  
  5. :if (([/system health get temperature]>$tempbeep) || ([/system health get voltage]>$volbeep)) do={  
  6. :beep length=200ms frequency=3000  
  7. :delay 200ms  
  8. :beep length=200ms frequency=3500  
  9. :delay 200ms  
  10. :beep length=200ms frequency=3000  
  11. :delay 200ms  
  12. :beep length=200ms frequency=3500  
  13. :delay 200ms  
  14. :beep length=200ms frequency=3000  
  15. :delay 200ms  
  16. }  

 首先你的RB设备必须具备温度传感器和电压传感器,否则请不要使用。

» 阅读全文

Tags: ros, 温度, 电压, 报警, 监测

服务器迁移完毕...

roslog全部资料丢失,请用户重新注册使用。
其他本站带网络验证的软件请联系作者获取更新版本。
NTP对时服务已恢复,请更新服务器IP为123.57.72.35

» 阅读全文

Tags: 服务器, 验证, 软件, 迁移

商品的贵与便宜并非仅仅由价格来决定

大家平时买东西都明白一个道理就是性价比,但是这个道理往往到了虚拟商品及半虚拟商品就开始淡化了。买东西越来越多只是凭着一时的热情,忽略了自己真正的需求。我是做网络的,我就先举个网络产品的例子吧。

大部分用户对路由的需求是以下类型:(按重要性排序)
1.产品稳定。死机,重启什么的不能有。
2.产品安全。系统必须安全,不会被黑掉或劫持。
3.产品效果,功能,扩展性。使用这个产品和之前产品比较能带来什么网络质量提升或功能提升。
4.使用产品附加成本。使用这个产品需要购买什么附加设备,需要额外增加或调整什么网络结构。
5.产品服务。使用这个产品是否有长期稳定可靠的服务,为你服务的人是否具备维护资格,是否技术过关。
6.维护成本。用户需要花多少时间去维护这个设备。
7.产品品牌文化。品牌文化决定这这个产品的特性,比如TP是便宜,ubnt是无线。这个品牌的文化是否符合你的发展需求。

比如网吧用户或者小区用户。很多时候用户被产品介绍冲昏了头脑得到的产品结果是出现各种问题,也许你觉得没有花多少钱,甚至没花钱,但是你损失的远不止你想象的这么多。如果你的竞争对手用的产品效果比你的好,他的生意也会比你好,他的提升就是你的损失。神马?理解不了?消费群体是趋于固定的,他的消费者多了是不是你的就少了?明白了么?他也许花的产品成本比你高,但是损失的却不是他,因为对于他增加的利润,这么点成本已经不算什么了。如果你还在继续使用存在问题的产品,你的消费者会越来越少。
来个比较简单的比较。产品A收费每月300,产品B免费。商家A每月收入每月30000,商家B每月收入30000。商家A使用产品A后因为网络质量提升每月收入提升到33000。商家B使用产品B由于经常断线,丢包,延时,收入降至27000。那么商家A使用A产品的成本是可以多赚2700,商家B使用B产品每月至少减少3000的收入。如果商家A和B继续坚持下去,这个差距还会继续拉大。这才是用户真正所承担的成本,而并非那每月300的价格。
当然以上比较都是针对老板级别的用户,如果你是网管或者只是一个维护的技术员。这些损失都不是你的损失,只是老板会觉得这是你的问题,你损失的是这份工作。

» 阅读全文

Tags: 商品, , 便宜, 价格

【通知】本站DNSPOD对接API接口已修复

本站DNSPOD对接API接口失效
从2014.10.16开始失效,恢复时间不明,需要等到官方发布新的API文档。
2014/10/17 10:34

本站DNSPOD对接API接口已修复
2014/10/17 19:00

» 阅读全文

Tags: dnspod, ddns, api, 对接, 接口

ROS防御内网攻击

本策略适用于防范UDP流量攻击(比如阿拉丁UDP攻击器)。TCP连接数攻击限制下单机连接数就行了,我就不多说了。

首先要新建一个网桥,将自己内网卡加入到桥接。

ROS防火墙脚本
  1. /interface bridge settings set use-ip-firewall=yes
  2. /ip firewall filter add action=add-src-to-address-list address-list=att address-list-timeout=10m chain=input connection-rate=10M-4294967295 protocol=udp src-address=192.168.0.0/24
  3. /ip firewall mangle add action=add-src-to-address-list address-list=att address-list-timeout=10m chain=postrouting connection-rate=10M-4294967295 protocol=udp src-address=192.168.0.0/24

修改IP为自己的内网IP地址范围。

ROS计划任务脚本
  1. :global attip
  2. :global defint
  3. :global taa 0
  4. :global nowmonth
  5. :global allmonth jan,feb,mar,apr,may,jun,jul,aug,sep,oct,nov,dec
  6. :foreach lizi in=[$allmonth] do={
  7. :if ([:pick [/system clock get date] 0 3]=$lizi) do={
  8. :set nowmonth ($taa+1)}
  9. :set taa ($taa + 1)}
  10. :global atttime ([:pick [/system clock get date] 7 11].$nowmonth.[:pick [/system clock get date] 4 6]."-".[/system clock get time]);
  11. :foreach fatt in=[/ip firewall address-list find list=att] do={
  12. :set attip [/ip firewall address-list get $fatt address]
  13. :if ([/interface bridge nat find arp-dst-address=($attip."/32")]="") do={
  14. /interface bridge nat add action=src-nat arp-dst-address=($attip."/32") chain=srcnat mac-protocol=arp comment=("att-".$atttime)}}
  15. :foreach fattd in=[/interface bridge nat find] do={
  16. :if ([/ip firewall address-list find list=att address=[:pick [/interface bridge nat get $fattd arp-dst-address] 0 ([:len [/interface bridge nat get $fattd arp-dst-address]]-3)]]="") do={
  17. /interface bridge nat remove $fattd}}

设置为定时循环执行,建议间隔时间为3-5秒左右为宜。

本策略原理是将攻击者的IP记录下来,加入攻击者的IP到桥防火墙,攻击者的IP将在ARP缓存超时后(WIN7系统5次测试计算后得到平均值为20秒左右。)无法和ROS通讯,因为找不到ROS的MAC,包括流量攻击也打不上来,因为找不到目标。(进入桥防火墙后即使攻击者再手工绑定路由MAC也无法成功。)
缺点:若客户机在攻击前已绑定路由MAC,则防御无法生效。因为ARP缓存不会超时。

» 阅读全文

Tags: ros, 内网, 攻击, udp, 流量